Overview:

Microsoft has rolled out Windows 10 20H1 on 27th May 2020 also known as Version 2004 (Vibranium) and codenamed "20H1”.

The R&D team has verified the compatibility of Seqrite Endpoint Security on Windows 10 20H1 [Version 2004] and there are no changes in the binaries for supporting Seqrite EPS on Windows 10 20H1 [Version 2004].


Support Matrix for Windows 10 20H1 [Version 2004] May 2020 update:

Scenario

Seqrite EPS

7.2 & above

Seqrite EPS

7.1 & 7.0

Seqrite EPS 6.4 & Below

Fresh Install on Win 10 20H1 [Version 2004]

Supported

Not Supported

Not Supported

Upgrade to Win 10 20H1 [Version 2004]

Supported

Not Supported

Not Supported


Note: The above matrix is applicable for English and localized versions of Seqrite EPS.


Below are few FAQs which will help your understanding of the Support for Windows 10 20H1 [Version 2004]:

  1. What versions of Seqrite Endpoint Security are supported on Windows 10 20H1 [Version 2004]?

Answer

  1. Seqrite EPS having version 7.2 & above with latest VDB are supported for Windows 10 20H1 [Version 2004]
  2. Clean installation with Seqrite EPS 7.1 & below version is not supported on Windows 10 20H1 [Version 2004]
  3. A system restart is recommended after taking the latest updates before Windows 10 20H1 [Version 2004] update.

2. When does the Seqrite EPS support for Windows 10 20H1 [Version 2004] begin?

Answer –

       There is no update release planned specifically for supporting on Win 10 20H1 [Version 2004] as there are no changes in any binaries.


3. Is ‘Clean install’ supported on Win 10 20H1 [Version 2004]?

Answer

  1. Yes, a clean install is supported with Seqrite EPS 7.2 & above.
  2. For clean install with Seqrite EPS 7.2 & above use updated Client AV builds for the available EPS versions.
  3. As stated in earlier points, Clean install on Seqrite EPS 7.1 and below are not supported for Windows 10 20H1 [Version 2004].

4. Do we support the upgrade of the Windows system to Windows 10 20H1 [Version 2004] with existing Seqrite EPS Versions?

Answer –

  • Yes, Upgrades are supported. Seqrite EPS 7.2 and above running on systems must take the latest definition updates and then proceed for Windows upgrade to Windows 10 20H1. Failing to do so will result in inconsistent behavior of Seqrite EPS or System.

5. Are there any blogs published on the Seqrite website for confirming the support of Windows 10 20H1 [Version 2004]?

Answer

Yes. Link is as follows:

https://www.seqrite.com/blog/seqrite-eps-supports-windows-10-may-2020-update-20h1/


6. Limitations, if any?

Answer

Yes,

  1. Seqrite EPS 7.1 and below versions are not supported on Windows 10 20H1 [Version 2004]
  2. Seqrite EPS 7.2 & above versions with the latest VDB are supported for Windows 10 20H1 [Version 2004] Upgrade.
  3. Seqrite EPS Client running on systems with Win 10 RS5 [Version 1809] or lower Operating system must take the latest definition updates and then proceed for Windows upgrade to Win 10 20H1 [Version 2004]. Failing to do so will result in inconsistent behavior of Seqrite EPS or System.
  4. DNA Scan warning or False detection of Windows file may appear during the fresh installation of EPS 7.2 Clients on Windows 10 20H1 [Version 2004] for other than EPS Client AV build 10.3.1.6 released on 6 March 2019. Once EPS is updated with the latest VDB, no further prompt of DNA Scan warnings or False detection shall appear.
  5. Fresh installation and upgrade are not supported with Seqrite EPS 6.4 and earlier versions.
  6. Known issue(s) specific to Windows 10 20H1: None

Please contact Seqrite Technical Support for more assistance.